<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link type="text/css" media="all" href="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/cache/autoptimize/css/autoptimize_cd34a876cba9fd0a5076bd0280e90c9c.css" rel="stylesheet" /><title>Former Arkansas RB Knile Davis embracing opportunity with the Pittsburgh Steelers</title><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://www.saturdaydownsouth.com/xmlrpc.php"><link rel="icon" type="image/png" href="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/themes/sds-3/images/sdsfavicon.png"><link href="https://fonts.googleapis.com/css?family=Arbutus+Slab" rel="stylesheet"><link rel="canonical" href="https://www.saturdaydownsouth.com/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/" /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Saturday Down South &raquo; Feed" href="https://www.saturdaydownsouth.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Saturday Down South &raquo; Comments Feed" href="https://www.saturdaydownsouth.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Saturday Down South &raquo; Former Arkansas RB Knile Davis embracing opportunity with the Pittsburgh Steelers Comments Feed" href="https://www.saturdaydownsouth.com/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.saturdaydownsouth.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='https://api.w.org/' href='https://www.saturdaydownsouth.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.saturdaydownsouth.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.saturdaydownsouth.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.saturdaydownsouth.com/?p=170423' /><link rel="alternate" type="application/json+oembed" href="https://www.saturdaydownsouth.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.saturdaydownsouth.com%2Farkansas-football%2Fformer-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.saturdaydownsouth.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.saturdaydownsouth.com%2Farkansas-football%2Fformer-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers%2F&#038;format=xml" /><link rel="amphtml" href="https://www.saturdaydownsouth.com/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/amp/" /><meta property="al:ios:url" content="saturdaydownsouth://www.saturdaydownsouth.com/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/"/><meta property="al:ios:app_store_id" content="1141922383" /><meta property="al:ios:app_name" content="Saturday Down South" /><meta property="og:title" content="Former Arkansas RB Knile Davis embracing opportunity with the Pittsburgh Steelers"/><meta property="og:description" content="Ex-Razorback hoping to make an impact after falling off the grid in Kansas City the past couple of seasons."/><meta property="al:web:url" content="https://www.saturdaydownsouth.com/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/"/><meta property="og:site_name" content="Saturday Down South"/><meta property="og:url" content="https://www.saturdaydownsouth.com/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/"/><meta property="og:image" content="https://www.saturdaydownsouth.com/wp-content/uploads/2017/06/USATSI_9593742-1024x512.jpg"/><meta property="og:type" content="article"><meta property="article:publisher" content="https://www.facebook.com/SaturdayDownSouth"><meta property="article:section" content="Sports"><meta property="article:published_time" content="2017-06-04T11:30:29+00:00"><meta property="fb:app_id" content="267502890122647" /><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:creator" content="@SDS" /><meta name="twitter:title" content="Former Arkansas RB Knile Davis embracing opportunity with the Pittsburgh Steelers"/><meta name="twitter:description" content="Ex-Razorback hoping to make an impact after falling off the grid in Kansas City the past couple of seasons."/><meta name="twitter:image" content="https://www.saturdaydownsouth.com/wp-content/uploads/2017/06/USATSI_9593742-1024x512.jpg"/><link href="https://plus.google.com/112599646279611249154" rel="publisher" /> <script>//old analytics -   ga('create', 'UA-17063376-1', 'auto');</script> <link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2016/09/sds-57.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2016/09/sds-114.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2016/09/sds-72.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2016/09/sds-144.png" /><link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2016/09/sds-60.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2016/09/sds-120.png" /><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2016/09/sds-76.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2016/09/sds-152.png" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-69793287-1', 'auto');
  ga('require', 'displayfeatures');

  ga('set', 'dimension1', 'arkansas');  ga('set', 'dimension2', 'article');  ga('set', 'dimension3', 'Logged Out');  ga('set', 'dimension4', 'News');  ga('send', 'pageview');</script>  <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script> <script>var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];</script> <script type='text/javascript'>googletag.cmd.push(function() {

            var mapHeader = googletag.sizeMapping()
                .addSize([1000, 200], [[970, 250], [970, 90], [728, 90], [1,1]])
                .addSize([768, 200], [[728, 90], [1,1]])
                .build();

            var mapArticleTopRight = googletag.sizeMapping()
                .addSize([768, 200], [[300, 250],[300,1050]])
                .build();

            var mapInArticle = googletag.sizeMapping()
                .addSize([1000, 200], [[970, 250], [970, 90], [728, 90], [1,1]])
                .addSize([768, 200], [[728, 90], [1,1]])
                .build();

            var mapSidebarBot = googletag.sizeMapping()
                .addSize([1000, 200], [300, 600])
                .build();

        window.HeaderSlot = googletag.defineSlot('/16352531/SDS_Header', [[300, 250], [320, 480], [320, 50], [300, 50]], 'div-gpt-ad-1425592040408-3')
        .defineSizeMapping(mapHeader).addService(googletag.pubads()).setTargeting("team","arkansas").setTargeting("author","adamspencer").setTargeting("content","article").setTargeting("loggedin","out").setTargeting("series","noseries");

        window.SidebarTopSlot = googletag.defineSlot('/16352531/SDS_Article_Top_Right', [0, 0], 'div-gpt-ad-1425592040408-6')
        .defineSizeMapping(mapArticleTopRight).addService(googletag.pubads()).setTargeting("team","arkansas").setTargeting("author","adamspencer").setTargeting("content","article").setTargeting("loggedin","out").setTargeting("series","noseries");

        window.SidebarBotSlot = googletag.defineSlot('/16352531/SDS_Comments_Right', [300, 250], 'div-gpt-ad-1425592040408-4')
        .defineSizeMapping(mapSidebarBot).addService(googletag.pubads()).setTargeting("team","arkansas").setTargeting("author","adamspencer").setTargeting("content","article").setTargeting("loggedin","out").setTargeting("series","noseries");

        window.MobileArticleSlot = googletag.defineSlot('/16352531/SDS_Mid_Article', [[300, 250], [320, 480], [320, 50], [300, 50]], 'div-gpt-ad-1412279738174-0')
        .defineSizeMapping(mapInArticle).addService(googletag.pubads()).setTargeting("team","arkansas").setTargeting("author","adamspencer").setTargeting("content","article").setTargeting("loggedin","out").setTargeting("series","noseries");

        window.MobileBottomSlot = googletag.defineSlot('/16352531/SDS_Bottom_Article', [300, 250], 'div-gpt-ad-1412279738174-1')
        .defineSizeMapping(mapInArticle).addService(googletag.pubads()).setTargeting("team","arkansas").setTargeting("author","adamspencer").setTargeting("content","article").setTargeting("loggedin","out").setTargeting("series","noseries");

          googletag.defineSlot('/16352531/SDS_Interstitial', [1, 1], 'div-gpt-ad-1469215137559-0').addService(googletag.pubads()).setTargeting("team","arkansas").setTargeting("author","adamspencer").setTargeting("content","article").setTargeting("loggedin","out").setTargeting("series","noseries");
          googletag.pubads();
          googletag.enableServices();

          });</script>  <script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/saturdaydownsouth/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}</script>  <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '390059731355531', {
em: 'insert_email_variable,'
});
fbq('track', 'PageView');</script> <noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=390059731355531&ev=PageView&noscript=1"
/></noscript></head><body class="article-template-default single single-article postid-170423 single-format-standard"><div id='div-gpt-ad-1469215137559-0'> <script type='text/javascript'>googletag.cmd.push(function() {
                    googletag.display('div-gpt-ad-1469215137559-0');
                });</script> </div><div id="fb-root"></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=267502890122647&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <script type="text/javascript" async src="https://platform.twitter.com/widgets.js"></script> <section id="header-ad-space" class="header-ad-space"><div id='div-gpt-ad-1425592040408-3'> <script type='text/javascript'>googletag.cmd.push(function() {
                    googletag.display('div-gpt-ad-1425592040408-3');
                });</script> </div></section><header id="masthead" class="site-header" role="banner"><div class="top-nav-wrap"><nav class="top-team-nav"> <a href="/"><div class="sds-logo main-sprite"></div></a><ul class="team-icons"><li><a href="/sec-football/" class="main-sprite header-icon header-sec"></a></li><li><a href="/alabama-football/" class="main-sprite header-icon header-alabama"></a></li><li><a href="/arkansas-football/" class="main-sprite header-icon header-arkansas"></a></li><li><a href="/auburn-football/" class="main-sprite header-icon header-auburn"></a></li><li><a href="/florida-football/" class="main-sprite header-icon header-florida"></a></li><li><a href="/georgia-football/" class="main-sprite header-icon header-georgia"></a></li><li><a href="/kentucky-football/" class="main-sprite header-icon header-kentucky"></a></li><li><a href="/lsu-football/" class="main-sprite header-icon header-lsu"></a></li><li><a href="/mississippi-state-football/" class="main-sprite header-icon header-mississippi-state"></a></li><li><a href="/ole-miss-football/" class="main-sprite header-icon header-ole-miss"></a></li><li><a href="/mizzou-football/" class="main-sprite header-icon header-mizzou"></a></li><li><a href="/south-carolina-football/" class="main-sprite header-icon header-south-carolina"></a></li><li><a href="/tennessee-football/" class="main-sprite header-icon header-tennessee"></a></li><li><a href="/tamu-football/" class="main-sprite header-icon header-tamu"></a></li><li><a href="/vanderbilt-football/" class="main-sprite header-icon header-vanderbilt"></a></li></ul><div class="ham-menu-wrap"> <a href="javascript:void(0);" id="ham-menu" class="ham-menu main-sprite"></a></div><div id="mobile-menu" class="mobile-menu"><ul class="mobile-drop-down"><li><span class="main-sprite mobile-icon mobile-teams"></span><a href="javascript:void(0);" id="mobile-team-select">TEAMS</a></li><li><span class="main-sprite mobile-icon mobile-news"></span><a href="arkansas-football">NEWS</a></li><li><span class="main-sprite mobile-icon mobile-schedule"></span><a href="https://www.saturdaydownsouth.com/schedules/arkansas-games/2017-arkansas-football-schedule/">SCHEDULE</a></li><li><span class="main-sprite mobile-icon mobile-tickets"></span><a href="https://www.ticketcity.com/college-football/arkansas-razorbacks-football-tickets.html">TICKETS</a></li><li><span class="main-sprite mobile-icon mobile-about"></span><a href="/information/">ABOUT US</a></li><li><span class="main-sprite mobile-icon mobile-shop"></span><a href="https://sdsnation.com/collections/fayetteville-ar">SHOP</a></li><li><span class="main-sprite mobile-icon mobile-profile"></span><a href="/login-or-register/?redirect_to=https://www.saturdaydownsouth.com/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/">LOGIN / REGISTER</a></li></ul></div><div id="mobile-team-menu" class="mobile-team-menu"> <a href="/alabama-football/"><div class="team-tag alabama-football-background"> <span class="main-sprite alabama-football-tag team-tag-icon"></span> <span class="team-tag-label">ALABAMA</span></div> </a> <a href="/arkansas-football/"><div class="team-tag arkansas-football-background"> <span class="main-sprite arkansas-football-tag team-tag-icon"></span> <span class="team-tag-label">ARKANSAS</span></div> </a> <a href="/auburn-football/"><div class="team-tag auburn-football-background"> <span class="main-sprite auburn-football-tag team-tag-icon"></span> <span class="team-tag-label">AUBURN</span></div> </a> <a href="/florida-football/"><div class="team-tag florida-football-background"> <span class="main-sprite florida-football-tag team-tag-icon"></span> <span class="team-tag-label">FLORIDA</span></div> </a> <a href="/georgia-football/"><div class="team-tag georgia-football-background"> <span class="main-sprite georgia-football-tag team-tag-icon"></span> <span class="team-tag-label">GEORGIA</span></div> </a> <a href="/kentucky-football/"><div class="team-tag kentucky-football-background"> <span class="main-sprite kentucky-football-tag team-tag-icon"></span> <span class="team-tag-label">KENTUCKY</span></div> </a> <a href="/lsu-football/"><div class="team-tag lsu-football-background"> <span class="main-sprite lsu-football-tag team-tag-icon"></span> <span class="team-tag-label">LSU</span></div> </a> <a href="/mizzou-football/"><div class="team-tag mizzou-football-background"> <span class="main-sprite mizzou-football-tag team-tag-icon"></span> <span class="team-tag-label">MISSOURI</span></div> </a> <a href="/mississippi-state-football/"><div class="team-tag mississippi-state-football-background"> <span class="main-sprite mississippi-state-football-tag team-tag-icon"></span> <span class="team-tag-label">MISS. STATE</span></div> </a> <a href="/ole-miss-football/"><div class="team-tag ole-miss-football-background"> <span class="main-sprite ole-miss-football-tag team-tag-icon"></span> <span class="team-tag-label">OLE MISS</span></div> </a> <a href="/south-carolina-football/"><div class="team-tag south-carolina-football-background"> <span class="main-sprite south-carolina-football-tag team-tag-icon"></span> <span class="team-tag-label">S. CAROLINA</span></div> </a> <a href="/tennessee-football/"><div class="team-tag tennessee-football-background"> <span class="main-sprite tennessee-football-tag team-tag-icon"></span> <span class="team-tag-label">TENNESSEE</span></div> </a> <a href="/tamu-football/"><div class="team-tag tamu-football-background"> <span class="main-sprite tamu-football-tag team-tag-icon"></span> <span class="team-tag-label">TEXAS A&M</span></div> </a> <a href="/vanderbilt-football/"><div class="team-tag vanderbilt-football-background"> <span class="main-sprite vanderbilt-football-tag team-tag-icon"></span> <span class="team-tag-label">VANDERBILT</span></div> </a></div></nav></div><div class="sub-nav-background"><div class="sub-nav-wrap"><div class="sub-right"><ul class="sub-right-menu"><li><a href="javascript:void(0);" id="search-icon" class="main-sprite header-icon header-search"></a></li><form method="get" id="searchform" action="https://www.saturdaydownsouth.com/"> <input type="text" placeholder="Start typing to search..." id="s" name="s"></form><li><a href="javascript:void(0);" class="main-sprite header-icon header-profile" id="login-reg-button"></a></li></ul><form action="https://www.saturdaydownsouth.com/wp-login.php" method="POST" id="nav-login-form"><div class="form-wrapper"> <input type="text" placeholder="Username or Email Address" name="log" value="" id="user_login"> <input type="password" placeholder="Password (case sensitive)" name="pwd" value="" id="user_pass"> <input type="hidden" name="redirect_to" value="/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/"> <button type="submit" class="nav-btn nav-login-submit">Log In</button><p class="forgot"><a href="https://www.saturdaydownsouth.com/reset-password/" class="forgot-link">Forgot <strong>username</strong> or <strong>password</strong>?</a></p> <a href="/login-or-register/" class="nav-btn nav-sign-up">Sign up</a></div></form></div><nav class="sub-nav"><ul class="sub-menu"><li><a href="arkansas-football">NEWS</a></li><li><a href="https://www.saturdaydownsouth.com/schedules/arkansas-games/2017-arkansas-football-schedule/">SCHEDULE</a></li><li><a href="https://www.ticketcity.com/college-football/arkansas-razorbacks-football-tickets.html">TICKETS</a></li><li><a href="/information/">ABOUT US</a></li><li><a href="https://sdsnation.com/collections/fayetteville-ar">SHOP</a></li></ul></nav></div></div></header><main id="content"><section class="single-article-section"><article id="article-170423" class="featured-article arkansas-football-article"><div class="featured-article-content arkansas-football-feature"><div class="team-tag arkansas-football-background"> <span class="main-sprite arkansas-football-tag team-tag-icon"></span> <span class="team-tag-label">ARKANSAS</span></div><div class="featured-article-image"><div class="blurry-load-container blurry-feature"> <img class="image-blur" id="feat-image" src="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/USATSI_9593742-71x49.jpg" data-large="https://www.saturdaydownsouth.com/wp-content/uploads/2017/06/USATSI_9593742-718x490.jpg"/> <noscript> <img id="feat-image" src="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/USATSI_9593742-718x490.jpg"/><style>img.image-blur { display:none; }</style></noscript></div></div><div class="featured-article-info"><h2><span>Former Arkansas RB Knile Davis embracing opportunity with the Pittsburgh Steelers</span></h2><div class="feature-meta"><span>Adam Spencer | 8 seconds ago</span></div><div class="social-share"> <a href="https://www.facebook.com/dialog/share?&display=popup&app_id=421796554838668&href=https://www.saturdaydownsouth.com/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/&redirect_uri=https://www.saturdaydownsouth.com/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/"><div class="facebook-share"><span class="main-sprite social-share-icon facebook-share-icon"></span><span class="social-action">SHARE</span></div> </a> <a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.saturdaydownsouth.com%2Farkansas-football%2Fformer-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers%2F&text=Former+Arkansas+RB+Knile+Davis+embracing+opportunity+with+the+Pittsburgh+Steelers"><div class="twitter-share"><span class="main-sprite social-share-icon twitter-share-icon"></span><span class="social-action">TWEET</span></div> </a></div><div style="clear:both;"></div></div></div><div class="article-body"><div class="top-right-ad"><div style='margin:10px auto;'><div id='div-gpt-ad-1425592040408-6'> <script type='text/javascript'>googletag.cmd.push(function() {
                    googletag.display('div-gpt-ad-1425592040408-6');
                });</script> </div></div></div><p>After the Kansas City Chiefs selected him in the third round of the 2013 NFL Draft, former Arkansas RB Knile Davis made an immediate impact.</p><p>During the 2014 season, he ran for 463 yards and six touchdowns and also contributed in the return game, running one kickoff back for a score.</p><p>However, during the 2015 and 2016 seasons, Davis fell off the map, losing playing time and his roster spot. After temporarily joining the Green Bay Packers last season, he ended up rejoining the Chiefs, but still didn&#8217;t see much action.</p><p>Now, he&#8217;s a member of the Pittsburgh Steelers and, <a href="http://www.post-gazette.com/sports/steelers/2017/06/04/Steelers-running-back-Knile-Davis-Chiefs-kickoff-return/stories/201705310232" target="_blank" rel="noopener noreferrer">according to the <em>Pittsburgh Post-Gazette</em></a>, is eager to prove he still has a lot left in his tank:</p><blockquote><p>“No doubt, I’m ready to get back on the scene,” said Davis, who signed a one-year deal worth $775,000. “I’m comfortable playing the game. I know a lot more about the game. It’s my fifth year. I’m very confident. I know what’s going on, on and off the field, the business side of it. It’s like a coming back party. I’d like to redeem myself, for sure.”</p></blockquote><p>Though the Steelers have one of the best running backs in the league in Le&#8217;Veon Bell and a rookie backup in James Conner, Davis said he still feels he has a place in Pittsburgh:</p><blockquote><p>“I’m a veteran running back,” Davis said. “I’ve done some good things in this league. I’m just trying to build on that and bring it here.”</p></blockquote><p>Davis has also served as a kickoff returner in his NFL career, something the Steelers could certainly use after going through five different players at that spot last year.</p></div><div class="author-box"><div class="author-image"><img alt='' src='https://secure.gravatar.com/avatar/bbdd1b137392f227d5d60f5e4af65a99?s=50&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/bbdd1b137392f227d5d60f5e4af65a99?s=100&amp;d=mm&amp;r=pg 2x' class='avatar avatar-50 photo' height='50' width='50' /></div><div class="author-text"> Connect with Adam via <a href="mailto:adamspencermu@gmail.com">email</a>, <a href="https://twitter.com/">Twitter</a> or <a href="https://facebook.com/">Facebook</a>.</div></div></article></section><section class="next-article"><div class="next-article-info"><div class="info-wrapper"><div class="feature-meta"><span>Will Ogburn | 16 hours ago</span></div><h3><span><a href="https://www.saturdaydownsouth.com/arkansas-football/arkansas-lands-commitment-versatile-state-athlete-sean-michael-flanagan/">Arkansas lands commitment from versatile in-state athlete Sean Michael Flanagan</a></span></h3><div class="excerpt"><span>Bret Bielema added a Swiss Army Knife for his new-look defense on Saturday.</span></div><div class="button-wrapper"> <a href="https://www.saturdaydownsouth.com/arkansas-football/arkansas-lands-commitment-versatile-state-athlete-sean-michael-flanagan/" class="next-article-button read-more-button">READ NEXT ARTICLE</a></div></div></div> <a href="https://www.saturdaydownsouth.com/arkansas-football/arkansas-lands-commitment-versatile-state-athlete-sean-michael-flanagan/"><div class="next-article-image" style="background-image:url(https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/USATSI_9681462-722x380.jpg);"></div> </a></section><section class="home-recent"><div class="recent-articles-wrapper"><h5>Recent Articles</h5><article id="recent-1" class="recent-article"><div class="recent-article-content"><div class="recent-article-image next-blurry blurry-load-container"><a href="https://www.saturdaydownsouth.com/arkansas-football/arkansas-ad-jeff-long-says-regrets-one-hire-last-10-years/"> <img class="image-blur" id="next-article-1" src="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/USATSI_9532284_168381178_lowres-71x49.jpg" data-large="https://www.saturdaydownsouth.com/wp-content/uploads/2017/06/USATSI_9532284_168381178_lowres-722x380.jpg"/> <noscript> <img id="next-article-1" src="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/USATSI_9532284_168381178_lowres-722x380.jpg"/><style>img.image-blur { display:none; }</style></noscript> </a></div><div class="recent-article-info"><div class="feature-meta"> <span>Andrew Olson | 2 days ago</span><div class="main-sprite recent-logo arkansas-football-recent"></div></div><h3><span><a href="https://www.saturdaydownsouth.com/arkansas-football/arkansas-ad-jeff-long-says-regrets-one-hire-last-10-years/">Arkansas AD Jeff Long says he regrets one hire from last 10 years</a></span></h3></div></div></article><article id="recent-2" class="recent-article"><div class="recent-article-content"><div class="recent-article-image next-blurry blurry-load-container"><a href="https://www.saturdaydownsouth.com/arkansas-football/bret-jen-bielema-share-artsy-pregnancy-photos-twitter/"> <img class="image-blur" id="next-article-2" src="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2017/05/USATSI_9690153-71x49.jpg" data-large="https://www.saturdaydownsouth.com/wp-content/uploads/2017/05/USATSI_9690153-722x380.jpg"/> <noscript> <img id="next-article-2" src="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/uploads/2017/05/USATSI_9690153-722x380.jpg"/><style>img.image-blur { display:none; }</style></noscript> </a></div><div class="recent-article-info"><div class="feature-meta"> <span>Adam Spencer | 3 days ago</span><div class="main-sprite recent-logo arkansas-football-recent"></div></div><h3><span><a href="https://www.saturdaydownsouth.com/arkansas-football/bret-jen-bielema-share-artsy-pregnancy-photos-twitter/">Bret and Jen Bielema share artsy pregnancy photos on Twitter</a></span></h3></div></div></article><div style="clear:both;"></div><div class="more-links"><div id="taboola-below-article-thumbnails-2nd"></div> <script type='text/javascript'>/* width = document.documentElement.clientWidth;
        if (width > 900) { 

        <!--//
           document.MAX_ct0 ='';
           var m3_u = (location.protocol=='https:'?'https://cas.criteo.com/delivery/ajs.php?':'http://cas.criteo.com/delivery/ajs.php?');
           var m3_r = Math.floor(Math.random()*99999999999);
           document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
           document.write ("zoneid=179611");document.write("&amp;nodis=1");
           document.write ('&amp;cb=' + m3_r);
           if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
           document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
           document.write ("&amp;loc=" + escape(window.location).substring(0,1600));
           if (document.context) document.write ("&context=" + escape(document.context));
           if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {
               document.write ("&amp;ct0=" + escape(document.MAX_ct0));
           }
           if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
           document.write ("'></scr"+"ipt>");

        } else {
          
          window._taboola = window._taboola || [];
          _taboola.push({
            mode: 'thumbnails-g',
            container: 'taboola-below-article-thumbnails',
            placement: 'Below Article Thumbnails',
            target_type: 'mix'
          });

        }*/

  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-j',
    container: 'taboola-below-article-thumbnails-2nd',
    placement: 'Below Article Thumbnails 2nd',
    target_type: 'mix'
  });</script> </div><div style="clear:both;"></div></div></section></section><section class="comments-wrapper"><div class="comments-ad-unit"><div style='margin:10px auto;'><div id='div-gpt-ad-1425592040408-4'> <script type='text/javascript'>googletag.cmd.push(function() {
                    googletag.display('div-gpt-ad-1425592040408-4');
                });</script> </div></div></div><div id="comments" class="comments-area"><div class="title"><h3>Comments</h3></div><div style="clear:both;"></div><div class="comments-notice"><p>You must be logged in to post a comment. Please <a href="/login-or-register/?redirect_to=https://www.saturdaydownsouth.com/arkansas-football/former-arkansas-rb-knile-davis-embracing-opportunity-pittsburgh-steelers/" onclick="trackArticleLink('Comment Sign In');">sign in</a> or <a href="/login-or-register#reg" onclick="trackArticleLink('Comment Register');">register</a></div></div><div style="clear:both;"></div></section><div style="clear:both;"></div><section class="home-recent" id="read-more-articles"></section><section class="read-more"><a href="javascript:void(0);" id="read-more-button" class="read-more-button">Read More</a></section></main><footer></footer> <script type='text/javascript' src='https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.11.0'></script> <script type='text/javascript'>/*  */
var SdsAjax = {"ajaxurl":"https:\/\/www.saturdaydownsouth.com\/wp-admin\/admin-ajax.php"};
/*  */</script> 
 <script type='text/javascript'>window._taboola = window._taboola || [];
  _taboola.push({flush: true});</script>  <script type="text/javascript">var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-83sXDMzqoxSvY"
});</script> <noscript><div style="display:none;"> <img src="//pixel.quantserve.com/pixel/p-83sXDMzqoxSvY.gif" border="0" height="1" width="1" alt="Quantcast"/></div> </noscript><script>var om58986e7e49d86,om58986e7e49d86_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){om58986e7e49d86_poll(function(){if(window['om_loaded']){if(!om58986e7e49d86){om58986e7e49d86=new OptinMonsterApp();return om58986e7e49d86.init({"s":"960.58986e7e49d86","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="//a.optnmnstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;om58986e7e49d86=new OptinMonsterApp();om58986e7e49d86.init({"s":"960.58986e7e49d86","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script> <script type="text/javascript" defer src="https://2f13yq12csmv2yraq925m73i-wpengine.netdna-ssl.com/wp-content/cache/autoptimize/js/autoptimize_61ce125360a49380993bae1a96df4054.js"></script></body></html> <script type="text/javascript"></script>